Home | Download | Discussion | Help | Site Map | New Posts | Sign in

Latest Site News

New Creator Theme: Elders! - posted on 1st Sep 2018 at 11:43 AM
Replies: 15 (Who?), Viewed: 2906 times.
Test Subject
Original Poster
#1 Old 12th Mar 2018 at 1:37 AM Last edited by AuntMorticha24 : 12th Mar 2018 at 3:12 AM.
Default HELP CAW world keeps exporting older saved world
I have exported a world i made and then I needed to go back and work on it some more. I tried exporting the world after changes I had saved it and gave it a new name. Still the old world then I changed the id with s3pe. Still the old world. Is there a way to move the new caw world to the sims 3 game through S3PE or do i need to do something else. I have worked on this world for 8 months i would love to really play it thank you.
Advertisement
Field Researcher
#2 Old 12th Mar 2018 at 8:15 AM
Try uninstalling the old version of your world, with the launcher. Than go into your InstallWorlds file under your Documents > Electronic Arts >The Sims 3 folder to make sure the older version is gone. Idk why but the game won't update new versions of a world. It's a bit of a pain. I think it's why I make sure I have big changes before I export a world to the game.
dodgy builder
#3 Old 12th Mar 2018 at 9:13 AM
The way I did it was to give the world a new internal name by removing WPID 0xF609FD60 with s3pe. Save a backup first.

If you do that, the game will treat it as a new world. Make sure you give it a new name.
Scholar
#4 Old 12th Mar 2018 at 12:03 PM Last edited by Norn : 12th Mar 2018 at 3:11 PM.
You can't move CAW worlds into game with s3pe. So the steps are as follows:

1. As ruffdog24 wrote, make sure the old version is properly uninstalled (shouldn't be a problem if you changed the world ID but just to be on the safe side). Also make sure to delete the world caches in your Sims 3 User folder in the subfolder World Caches.
2. Make all changes you want in CAW. Save and quit.
3. Open the CAW world file with S3PE to delete the world ID as Volvenom desribed. Save. Don't use "save as", just save and quit.
4. Open CAW again, now do a Save As for your world, then close the world. Export the world with CAW (make sure to chose the correct version of your world).
5. Install world as you usually do.

Following these steps should solve/avoid the issue you described. Let us know if it works!
Lab Assistant
#5 Old 12th Mar 2018 at 2:08 PM Last edited by thesims1depot : 12th Mar 2018 at 3:23 PM.
I've exported worlds countless of times and have never had to use s3pe. I'm not saying anyone shouldn't use it, but just saying that for me, to avoid this issue, all it took was deleting folders inside the Electronic Arts/The Sims folders that contain files connected to the world. The folders are:

/Downloads (delete your world's .pack file)
/Exports (delete your world's .pack file)
/WorldCache (delete your world's .package file)

Also, OP, are you sure you're doing the process of saving and exporting your world correctly? I remember reading posts in the pasts of people who had exported their worlds before saving them. You are supposed to save your world, then export.

Also, are you sure you're clicking on the right export file you want installed? I always go straight to the /Exports folder to install my worlds, never the launcher.
Top Secret Researcher
#6 Old 12th Mar 2018 at 4:01 PM
I have never had to use S3PE either. As long as I have removed the prior version my new one installs. But the info. provided about using it when needed is helpful for those who will need to do this. Which may be me at a later date. :D
dodgy builder
#7 Old 12th Mar 2018 at 4:27 PM
Quote:
Originally Posted by Norn
You can't move CAW worlds into game with s3pe. So the steps are as follows:

1. As ruffdog24 wrote, make sure the old version is properly uninstalled (shouldn't be a problem if you changed the world ID but just to be on the safe side). Also make sure to delete the world caches in your Sims 3 User folder in the subfolder World Caches.
2. Make all changes you want in CAW. Save and quit.
3. Open the CAW world file with S3PE to delete the world ID as Volvenom desribed. Save. Don't use "save as", just save and quit.
4. Open CAW again, now do a Save As for your world, then close the world. Export the world with CAW (make sure to chose the correct version of your world).
5. Install world as you usually do.

Following these steps should solve/avoid the issue you described. Let us know if it works!


I don't really remember, but are you sure you have to take it back into caw after removing the world ID. Can't you just take it into the game.

I tried unistalling through the launcher several times. It never worked, so I just used this way instead. I might not have done it the right way, but I have learned there is several roads to solve most issues in this game.
Scholar
#8 Old 12th Mar 2018 at 6:52 PM
Quote:
Originally Posted by Volvenom
I don't really remember, but are you sure you have to take it back into caw after removing the world ID. Can't you just take it into the game.

I tried unistalling through the launcher several times. It never worked, so I just used this way instead. I might not have done it the right way, but I have learned there is several roads to solve most issues in this game.


Well, it's the way I do it and it worked 100% so far. I have no experience with your way - it might work just as well.
"My way" might not solve the issue with the launcher not uninstalling worlds properly - nothing can solve that issue, that's just a crappy EA programming. What you can try to solve that issue is A) deleting all files that are related to the installed worlds manually or B) starting with a clean user folder and C) to avoid this issue in the future not using sims3pack but packages to install custom worlds.
Test Subject
Original Poster
#9 Old 13th Mar 2018 at 3:21 AM
It finally worked I thought I had deleted the older one but i had not. Just one more thing when the world opened the bridges i had are all gone is there something i can do to get them to be in my game?
And I would like to thank everyone who has helped me out with this I have worked for so long on this world I would love to be able to play it finally.
Top Secret Researcher
#10 Old 13th Mar 2018 at 5:09 AM
Are they CC items? If so they need to be in your game as well as in CAW. I use Leroy sailboats for example and they will not show up in my game unless there as well as in CAW.
Test Subject
Original Poster
#11 Old 13th Mar 2018 at 11:20 AM
Default Worked
Quote:
Originally Posted by ruffdog24
Try uninstalling the old version of your world, with the launcher. Than go into your InstallWorlds file under your Documents > Electronic Arts >The Sims 3 folder to make sure the older version is gone. Idk why but the game won't update new versions of a world. It's a bit of a pain. I think it's why I make sure I have big changes before I export a world to the game.


It worked l made sure on the launcher page to delete the old version then clicked on the new one twice and it downloaded it.thank you for the help. But on my world I had bridges and they are not there how do I get them back?
Test Subject
Original Poster
#12 Old 13th Mar 2018 at 11:25 AM
Quote:
Originally Posted by thesims1depot
I've exported worlds countless of times and have never had to use s3pe. I'm not saying anyone shouldn't use it, but just saying that for me, to avoid this issue, all it took was deleting folders inside the Electronic Arts/The Sims folders that contain files connected to the world. The folders are:

/Downloads (delete your world's .pack file)
/Exports (delete your world's .pack file)
/WorldCache (delete your world's .package file)

Also, OP, are you sure you're doing the process of saving and exporting your world correctly? I remember reading posts in the pasts of people who had exported their worlds before saving them. You are supposed to save your world, then export.

Also, are you sure you're clicking on the right export file you want installed? I always go straight to the /Exports folder to install my worlds, never the launcher.


Thanks for your help it worked chanced the ID and made sure to delete the old and when I installed the new version I didn't use the launcher. But my bridges are gone now I have to figure out how to get them back?
Test Subject
Original Poster
#13 Old 13th Mar 2018 at 11:29 AM
Default How to Make sure
Quote:
Originally Posted by daisylee
Are they CC items? If so they need to be in your game as well as in CAW. I use Leroy sailboats for example and they will not show up in my game unless there as well as in CAW.


How do I check if they are in the game?
Lab Assistant
#14 Old 14th Mar 2018 at 2:44 AM
Quote:
Originally Posted by AuntMorticha24
Thanks for your help it worked chanced the ID and made sure to delete the old and when I installed the new version I didn't use the launcher. But my bridges are gone now I have to figure out how to get them back?


Were the bridges there before in your previous saves? But just aren't there now?

If so, are you sure you're doing the whole saving/exporting process correctly?
dodgy builder
#15 Old 14th Mar 2018 at 4:46 PM
Quote:
Originally Posted by AuntMorticha24
How do I check if they are in the game?


Did you install them via the launcher? I would suggest you learn how to use package files. It's going to save you lots of trouble in the long run. You can see what you have and they won't be there and be gone the next moment.

Read about CC here: http://simswiki.info/wiki.php?title...p:TS3_CC_Basics
It will also give you the links to install a mods folder and tell you how to set it up.

To use package files on store items you have to compressorize them. It's an ancient program I'm not sure would be considered legal anymore though Be aware that compressorize EA's sims3 pack files doesn't give you the right to give them to anyone who hasn't already paid for them.
Test Subject
Original Poster
#16 Old 18th Mar 2018 at 8:11 PM
Quote:
Originally Posted by thesims1depot
Were the bridges there before in your previous saves? But just aren't there now?

If so, are you sure you're doing the whole saving/exporting process correctly?


i changed the bridges and now they are there just would not show up the one i liked.
Back to top