Home | Download | Discussion | Help | Site Map | New Posts | Sign in

Latest Site News

2018 MTS Calendar Contest - posted on 12th Nov 2017 at 8:48 PM
Replies: 11 (Who?), Viewed: 760 times.
Lab Assistant
Original Poster
#1 Old 19th Aug 2017 at 8:04 AM

This user has the following games installed:

Sims 3, World Adventures, Ambitions, Late Night, Generations, Pets, Showtime, Supernatural
Default Sims 3 Crashing randomly at Save or at Save and Quit with "Acces Violation" as the cause
A couple of days ago my Sims 3 game started crashing, it has done it randomly 2 times, the first time is was during a save and it said: not enough memory, to turn down my specs.
My system specs:
Windows 7 Service pack 1
Intel Core i5-4460 CPU 3.20 GHz 3.20GHz
RAM 8,00GB
64 bits Operational System

Dedicated Video Card Nvidia 1050 2GB of Memory
GeForce Driver 385.28

The second time was when I was closing the game and did a save and quit and it said: SIms 3 stoped working and needs to close, Windows will try to find a solution to the problem.
The Crash Log analyzer does not come up with anything. I have Nraas: Error Trap, Master Controler, Overwatch, Saver, the ones that have made the game playable for me during the years.
I have not added any new piece of CC for a long time now, so the crashes caught me off-guard.
Things I have done so far:
Ran my CC through Delphys Dashboard (cleared)
Check for updated on my PC Bios and Drivers (OK)
Video Card Driver Updated Yesterday
Checked Ram memory to see if one of the sticks were going South, but came out clear
Took off DEP for Sims 3 and added them back again
I am including my device configuration file from My Sims 3 Game and the xcpt file that was generated after the last crash. I hope this helps in trying to figure out what is wrong with the game. I am trying to save me the time a hassle of a complete New Install, if possible.
I am not a computer wiz, so bare with me, what I've learned I have learned with the game through your forums, so play nice!
Thanking you in advance for any help regarding this matter
Download - please read all instructions before downloading any files!
File Type: rar DeviceConfig.rar (1.7 KB, 5 downloads) - View custom content
Description: Here is my Device Comfiguration for the game
File Type: rar xcpt USUARIO-PC 17-08-19 01.49.44.rar (4.8 KB, 2 downloads) - View custom content
Description: And this is The XCpt File that was generated after the lasted crash
Advertisement
Mad Poster
#2 Old 19th Aug 2017 at 9:43 AM
Honestly, crashing a couple of times is no big deal. It happens every now and then.

But if you're worried about memory.

1) Close all browsers and unnecessary programs. Especially Chrome. That thing takes literally gigabytes of memory.

2) Monitor your TS3 RAM usage when you save. Go into world view and try to save when the usage is 3GB or under.

3) For all you know, your save could be borked. Keep your saves clean by use Kurees or manually deleting snaps. Use NRAAS tools.

Nitromon is a type of Pokemon encountered in the Pokemon Nitrome Version series.

There. Mystery solved.
Lab Assistant
Original Poster
#3 Old 19th Aug 2017 at 10:46 AM
I play in Window mode, I use Mozilla firefox, but will delete Chrome, I don't use it.
The Video Card comes with a program that let's me tweak the GPU and I use it.
I have an HQ mod but have had it for a long time and a camera mod. I can build and use CAS without any problems the actual problem is when I am playing the town with a family. I thought that my first save could be borked, so I loaded a different save, however, it happened when I hit save and quit.
What is the # 3 item you mentioned of kurees or manually deleting snaps? I have most of NRAAS mods, I also use saver...
Lab Assistant
Original Poster
#4 Old 19th Aug 2017 at 10:53 AM
Things I've done since my last post:
Did a clean install of the Video Card Driver, in case there was a a problem with the 3d rendering
Did another RAM check no problems there. My GPU is running around 69 degrees during game play.
Mad Poster
#5 Old 19th Aug 2017 at 11:57 AM
I don't think you need to worry about your GPU. It doesn't seem to be GPU related. However, you mentioned HQ mod, I just need to confirm you're only using it for screenshots as it is not recommended to play with HQ mod.

When you are running, can you keep an eye on TS3's ram usage in task manager? At the same time, keep any eye on how much total RAM is being used. You can simply click the tab in task manager to performance to see how much total RAM is in usage.

You can google for Kuree's savegame cleaner if you are running 1.67. It is a tool to erase the Sims game memories and photos in the save, reducing the size of your save and ram usage. Also, make sure you have sims memories disabled in the game. If you have 1.69, you'll have to google on how to manually delete SNAPS from savegames.

Nitromon is a type of Pokemon encountered in the Pokemon Nitrome Version series.

There. Mystery solved.
Lab Assistant
Original Poster
#6 Old 19th Aug 2017 at 12:33 PM
I was going through the saves files and they are small compared to older save files 35.0MB compared to games I have of 98MB and over a hundred. I will try a new town and export a family I have saved in the bin and see what happens.
Lab Assistant
Original Poster
#7 Old 19th Aug 2017 at 2:29 PM
Quote:
Originally Posted by nitromon
I don't think you need to worry about your GPU. It doesn't seem to be GPU related. However, you mentioned HQ mod, I just need to confirm you're only using it for screenshots as it is not recommended to play with HQ mod.

When you are running, can you keep an eye on TS3's ram usage in task manager? At the same time, keep any eye on how much total RAM is being used. You can simply click the tab in task manager to performance to see how much total RAM is in usage.

You can google for Kuree's savegame cleaner if you are running 1.67. It is a tool to erase the Sims game memories and photos in the save, reducing the size of your save and ram usage. Also, make sure you have sims memories disabled in the game. If you have 1.69, you'll have to google on how to manually delete SNAPS from savegames.


Ok I will do that. I just Downloaded Kuree's savegame and I'm cleaning the saves, I also deleted all the temp files in dbc, I still need to clean Word Caches. I was using the HQ mode to play is actually, the s3hq which is an automatic one and I had it to 2048 setting on a x256 pixels! OK turning it off. I have another question for you: Since it only happens when I load a family and play with the game, never while in Editing, building a lot or a Sims; Could it be that one of the Sims in that family could be corrupted and if so, What would be a simple way to find out. I have 5 Sims in the current Household and 2 dogs. I also took out a mod that Delphy's dashboard picked up as conflicting with Daywalking Vampires + No sparkles was conflicting with the No stir crazy mod; however they had been both there forever. Could it also be the eye patch camera mod? Any other suggestions will be welcome. I have not slept all night working on this and will have a coffee overload, but will keep on until fixed. Thanks for your time and help, much appreciated!
Scholar
#8 Old 19th Aug 2017 at 3:42 PM
Quote:
Originally Posted by grieralexander
I have another question for you: Since it only happens when I load a family and play with the game, never while in Editing, building a lot or a Sims; Could it be that one of the Sims in that family could be corrupted and if so, What would be a simple way to find out. I have 5 Sims in the current Household and 2 dogs. I also took out a mod that Delphy's dashboard picked up as conflicting with Daywalking Vampires + No sparkles was conflicting with the No stir crazy mod; however they had been both there forever. Could it also be the eye patch camera mod? Any other suggestions will be welcome. I have not slept all night working on this and will have a coffee overload, but will keep on until fixed. Thanks for your time and help, much appreciated!


In addition to suggestions already posted, a few thing that might help you:

I did not see this suggested and hope I'm not repeating advice already given but have you tried a clean folder game?

The best way to find out if your family is causing the problems would be to remove them from your current game. Make a copy of your current game so you have it to revert back. Do a Save As and Quit. Clear caches and reload the game without the family.

Not all conflicts Delphy's Dashboard reports cause game problems. In many cases it means only that they are false positives using the same resource. Nona Mena has a guide with illustrations for using the Dashboard: The link for the original document with the illustrations is broken but you can dowload the PDF Here At Mediafire

Re DEP Settings you mentioned: Somewhere around Patch 1.63 and 1.67 DEP was disabled for S3 by default. You might want to check to make sure it is set at: "Use for essential Windows Programs and Services only."

Sorry I am not familiar with the camera mod. I'm sure someone else in here can answer that question.

For more suggestions, take a look at the Tips For Better Game Performance Document Here

Do you have NRaas Overwatch and Error Trap installed and if so are they generating Script Errors? If you do not have those mods installed you might want to consider installing those. Script errors can be read over at NRaas and often point to what is causing the problems. Free membership required. To upload see: How To Upload
Lab Assistant
Original Poster
#9 Old 19th Aug 2017 at 4:23 PM
Quote:
Originally Posted by barbarat
In addition to suggestions already posted, a few thing that might help you:

I did not see this suggested and hope I'm not repeating advice already given but have you tried a clean folder game?

The best way to find out if your family is causing the problems would be to remove them from your current game. Make a copy of your current game so you have it to revert back. Do a Save As and Quit. Clear caches and reload the game without the family.

Not all conflicts Delphy's Dashboard reports cause game problems. In many cases it means only that they are false positives using the same resource. Nona Mena has a guide with illustrations for using the Dashboard: The link for the original document with the illustrations is broken but you can dowload the PDF Here At Mediafire

Re DEP Settings you mentioned: Somewhere around Patch 1.63 and 1.67 DEP was disabled for S3 by default. You might want to check to make sure it is set at: "Use for essential Windows Programs and Services only."

Sorry I am not familiar with the camera mod. I'm sure someone else in here can answer that question.

For more suggestions, take a look at the Tips For Better Game Performance Document Here

Do you have NRaas Overwatch and Error Trap installed and if so are they generating Script Errors? If you do not have those mods installed you might want to consider installing those. Script errors can be read over at NRaas and often point to what is causing the problems. Free membership required. To upload see: How To Upload


I do have error trap and overwatch. I hardly get any errors except routing when a Sim is stuck and I usually go and see what is going since I play in Windowed mode and delete the object that may be causing the problem, usually an automatic, late night gate or bad furniture placement in a house. OK just made the change on DEP, since I did not know, DEP had been taken care off. Ok I am going to test the game with my last save and record the Ram usage and then will do with a new game with a different family and see how it works. I'll get back to you then. Thanks again!
Lab Assistant
Original Poster
#10 Old 19th Aug 2017 at 6:05 PM
I play tested and while in game I'm using 27% -34% of CPU and 61% of physical memory. I dis what I did the last time it crashed: Went into Edit Town - CAS and then back into the town and Saved it as Save As there I got bench marks from 5210MB - 5593MB of physical memory and 3118 available. let the game run into night time and hit save and quit. There I got bench marks of 1211- 2024, 2057 in cache and 422 free. There is a colored bar in the monitor process which tells you memory usage with colors bars: The green being the one being used and the blue is the free. The green bar was quite large during the save and quit and the free which is the blue went pretty low. I was afraid it was going to run out and crash but it didn't. It saved OK, which tells me that something we did worked. Mind you this is not turning any PC processes off while playing; which task manager says there are quite a bit, it is just that I really do not know which I can safely turn off. It never crossed my mind to turn them off, since the game has never lagged and this is the first time I had problems, since playing with this New Video Card. I have always kept memories and lessons off and my store image folder is empty because I have it as read only, so that the images do not regenerate. I forgot to mention that this is a Custom World Sunlit Tides V2, which fixed routing errors in the original, but also added things like an Airport, Golf Course and a Marina and Docks. I will try now on a Store World and see how those bench marks go, is there is a way I can record those for you to look at? Since I was shooting at what to look at and follow instinc on clicking on TS3 for the process monitoring, is just that the numbers change so fast. You are being a life saver. I was afraid I would have to do a clean install and add my mods and store stuff a little at a time.
Mad Poster
#11 Old 19th Aug 2017 at 11:20 PM
You can always take a screen capture of the stats you want to show us using frap or printscreen + editor.

People's first instinct is always reinstalling, which is a terrible idea b/c often it makes things worse. I can't really understand your last post, but it sounds like it is now working?

The situation you described is not uncommon if it randomly happens every now and then. It becomes a problem when it is consistent.

- Out of memory error during saves is pretty rare. Because not only does it require your system to be out of RAM, but it must also be out of virtual RAM and that almost never happens unless you did some custom tweak to the paging file. Now, I know some people who actually turned off their page file b/c they believe new systems with a lot of RAM doesn't require one. But since you are running only 8GB, which is standard, I highly doubt you did that.

So another likely culprit then is a broken mod which is leaking memory. The mod may not always be consistently broken, but only randomly during certain situations. This makes it hard to track down.

- "SIms 3 stoped working and needs to close" - This one is far more common and again, is not really a problem unless it is consistent. It can be random or it can also be memory related. It is also possible mod related or could just be save game corruption. My last save started having this more often. So I ended up completely overhauling the savegame by saving every sim and lot into the bin and start a new identical world, then placing all my lots and sims back down. The game now runs exceptionally well, without any possibility of this error or error 12. In my case, the problem was caused by awesome mod, which damaged the save so even after removing the mod, the save was still damaged.

So none of this really has anything to do with your GPU or your game installation. Most problems are often related to your user folder, mods, save games.

Nitromon is a type of Pokemon encountered in the Pokemon Nitrome Version series.

There. Mystery solved.
Lab Assistant
Original Poster
#12 Old 20th Aug 2017 at 3:40 AM
Quote:
Originally Posted by nitromon
You can always take a screen capture of the stats you want to show us using frap or printscreen + editor.

People's first instinct is always reinstalling, which is a terrible idea b/c often it makes things worse. I can't really understand your last post, but it sounds like it is now working?

The situation you described is not uncommon if it randomly happens every now and then. It becomes a problem when it is consistent.

- Out of memory error during saves is pretty rare. Because not only does it require your system to be out of RAM, but it must also be out of virtual RAM and that almost never happens unless you did some custom tweak to the paging file. Now, I know some people who actually turned off their page file b/c they believe new systems with a lot of RAM doesn't require one. But since you are running only 8GB, which is standard, I highly doubt you did that.

So another likely culprit then is a broken mod which is leaking memory. The mod may not always be consistently broken, but only randomly during certain situations. This makes it hard to track down.

- "SIms 3 stoped working and needs to close" - This one is far more common and again, is not really a problem unless it is consistent. It can be random or it can also be memory related. It is also possible mod related or could just be save game corruption. My last save started having this more often. So I ended up completely overhauling the savegame by saving every sim and lot into the bin and start a new identical world, then placing all my lots and sims back down. The game now runs exceptionally well, without any possibility of this error or error 12. In my case, the problem was caused by awesome mod, which damaged the save so even after removing the mod, the save was still damaged.

So none of this really has anything to do with your GPU or your game installation. Most problems are often related to your user folder, mods, save games.


Yes it has worked, so far. I have not tried a fresh game. All my sims and lots have been saved to the library and I can easily start a new game. On the last post I was trying to esplain about the bars that my system shows when tracking memory usage. I tried to explain the best I could, LOL. Now that you have mention that about the mod, I had a cigarette mod, which had given me script errors in the past and I had used the cigarette pack, which uses the mod in every new construction. Both games that crashed had this mod in place. I did remove it, but like you said, it may have borked my saves. Thank you so much for your help. If I run into the problem again, I will let you all know. Thanks for your help and patience!
Back to top